diff test/callback_plain/CMakeLists.txt @ 533:71c884e610f0

- integration of patches from Raphael Luba, Thekla, Inc.: * integration of aggregate-by-value (struct, union) support patch for x64 (win and sysv) * windows/x64 asm additions to specify how stack unwinds (help for debuggers, exception handling, etc.) * see Changelog for details - new calling convention modes for thiscalls (platform agnostic, was specific before) * new signature character for platform agnostic thiscalls ('*' / DC_SIGCHAR_CC_THISCALL) - dcCallF(), dcVCallF(), dcArgF() and dcVArgF(): * added support for aggregates-by-value (wasn't part of patch) * change that those functions don't implicitly call dcReset() anymore, which was unflexible (breaking change) - added macros to feature test implementation for aggregate-by-value and syscall support - changed libdyncall_s.lib and libdyncallback_s.lib order in callback test makefiles, as some toolchains are picky about order - doc: * man page updates to describe aggregate interface * manual overview changes to highlight platforms with aggregate-by-value support - test/plain: replaced tests w/ old/stale sctruct interface with new aggregate one
author Tassilo Philipp
date Thu, 21 Apr 2022 13:35:47 +0200
parents 3e629dc19168
children
line wrap: on
line diff
--- a/test/callback_plain/CMakeLists.txt	Sat Apr 16 15:00:58 2022 +0200
+++ b/test/callback_plain/CMakeLists.txt	Thu Apr 21 13:35:47 2022 +0200
@@ -1,4 +1,4 @@
 #
 add_executable(callback_plain callback_plain.c)
-target_link_libraries(callback_plain dyncallback_s)
+target_link_libraries(callback_plain dyncallback_s dyncall_s)