diff python/pydc/setup.py @ 28:edbbd467f50a

python binding: - update to dyncall 1.1 - Python 3 support (supports both, Python 2 and 3) - using the Capsule API over PyCObject, when available - support for python unicode strings (for both, Python 2 and 3) - doc cleanup ruby binding: - doc cleanup
author Tassilo Philipp
date Tue, 07 Apr 2020 21:16:37 +0200
parents 681db37a300c
children 2682a627168c
line wrap: on
line diff
--- a/python/pydc/setup.py	Sun Jan 12 12:10:38 2020 +0100
+++ b/python/pydc/setup.py	Tue Apr 07 21:16:37 2020 +0200
@@ -1,28 +1,28 @@
 from distutils.core import setup, Extension
 
 pydcext = Extension('pydcext',
-  sources = ['pydcext.c']
-,libraries=['dyncall_s','dynload_s']
+  sources   = ['pydcext.c']
+, libraries = ['dyncall_s','dynload_s']
 )
 
 setup(
   name             = 'pydc'
-, version          = '1.0'
+, version          = '1.1'
 , author           = 'Daniel Adler'
 , author_email     = 'dadler@dyncall.org'
 , maintainer       = 'Daniel Adler'
 , maintainer_email = 'dadler@dyncall.org'
-, url              = 'http://www.dyncall.org'
+, url              = 'https://www.dyncall.org'
+, download_url     = 'https://www.dyncall.org/download'
+, classifiers      = []
+#, packages         = ['pydc']
+#, package_dir      = ['dir']
+, ext_modules      = [pydcext]
+, py_modules       = ['pydc']
 , description      = 'dynamic call bindings for python'
 , long_description = '''
 dynamic call library allows to call arbitrary C library functions
 with a single call code (written in assembly)
 '''
-, download_url = 'http://www.dyncall.org/download'
-, classifiers=[]
-#, packages=['pydc']
-#, package_dir['dir']
-, ext_modules = [pydcext]
-, py_modules = ['pydc']
 )