diff python/pydc/setup.py @ 46:c21d1c2c84e1

- removed pydc.py wrapper overhead (which only called pydcext.so functions, directly, anyways) * implies renaming pydcext.* to pydc.* * while at it, iterate directly over args that are passed in (before we did extract fptr, sig and a tuple for the args and iterated over latter afterwards); we might have a tiny perf improvement now - added type stub as package_data
author Tassilo Philipp
date Fri, 13 Nov 2020 14:10:31 +0100
parents da553362fa7c
children edf5c85de5ac
line wrap: on
line diff
--- a/python/pydc/setup.py	Thu Nov 12 19:56:33 2020 +0100
+++ b/python/pydc/setup.py	Fri Nov 13 14:10:31 2020 +0100
@@ -1,13 +1,13 @@
 from distutils.core import setup, Extension
 
-pydcext = Extension('pydcext',
-  sources   = ['pydcext.c']
+pydcext = Extension('pydc',
+  sources   = ['pydc.c']
 , libraries = ['dyncall_s','dynload_s']
 )
 
 setup(
   name             = 'pydc'
-, version          = '1.1.4'
+, version          = '1.1.5'
 , author           = 'Daniel Adler, Tassilo Philipp'
 , author_email     = 'dadler@dyncall.org, tphilip@dyncall.org'
 , maintainer       = 'Daniel Adler, Tassilo Philipp'
@@ -18,11 +18,12 @@
 #, packages         = ['pydc']
 #, package_dir      = ['dir']
 , ext_modules      = [pydcext]
-, py_modules       = ['pydc']
 , description      = 'dynamic call bindings for python'
 , long_description = '''
-dynamic call library allows to call arbitrary C library functions
-with a single call code (written in assembly)
+library allowing to call arbitrary C library functions dynamically,
+based on a single call kernel (so no interface generation used/required)
 '''
+, package_data     = {"pydc-stubs": ['pydc.pyi']}
+, packages         = ["pydc-stubs"]
 )