diff python/pydc/setup.py @ 54:918dab7a6606

- added callback support (comes with some bigger refactoring) - allow CPython's Py{CObject,Capsule} to be used as 'p'ointers
author Tassilo Philipp
date Tue, 02 Feb 2021 20:42:02 +0100
parents 6387d39ecce2
children 8e905c0798c7
line wrap: on
line diff
--- a/python/pydc/setup.py	Fri Jan 22 15:18:56 2021 +0100
+++ b/python/pydc/setup.py	Tue Feb 02 20:42:02 2021 +0100
@@ -2,12 +2,12 @@
 
 pydcext = Extension('pydc',
   sources   = ['pydc.c']
-, libraries = ['dyncall_s','dynload_s']
+, libraries = ['dyncall_s','dyncallback_s','dynload_s']
 )
 
 setup(
   name             = 'pydc'
-, version          = '1.2.0'
+, version          = '1.2.5'
 , author           = 'Daniel Adler, Tassilo Philipp'
 , author_email     = 'dadler@dyncall.org, tphilip@dyncall.org'
 , maintainer       = 'Daniel Adler, Tassilo Philipp'
@@ -21,7 +21,9 @@
 , description      = 'dynamic call bindings for python'
 , long_description = '''
 library allowing to call arbitrary C library functions dynamically,
-based on a single call kernel (so no interface generation used/required)
+based on a single call kernel (so no interface generation used/required);
+also has callback support and helper functions to load shared objects and
+lookup symbols by name (including from running process itself)
 '''
 , package_data     = {'': ['pydc.pyi']}
 , packages         = ['']